Looper squeals, but only with other pedals

Sanchito

Electromatic
May 11, 2022
82
Washington, DC
A lekato loop station, which in every other way I love, emits a loud high pitched buzzing -- but only when other pedals are plugged in behind it. Some are better, some are worse -- the TCE Mojomojo is very bad, the BD-2 is pretty good -- but everything makes the lekato buzz, and I can't hear the buzz at all when it's the only thing in the signal chain. What's going on?

The obvious solution is to just get a different pedal of course but this has been the case with two of them, back to back -- and it's also been the case that two Ditto loopers have a noticable pause between loops when playing back, which I can't stand.

I could keep crawling up the ladder in terms of price, but it rises pretty quickly after these. I just want a looper that works as advertised!
 
Last edited:

Sanchito

Electromatic
May 11, 2022
82
Washington, DC
Sounds like you need the looper to have its own power supply. Are you using a daisy chain?
I'm using Donner DP-Z power supply, 60-70 bucks off amazon. I'm not sure if that means Yes or No though. It's got separate cords for each pedal, but I could try putting the looper on a separate rig entirely, by itself
 

kdm1218

Electromatic
Jun 17, 2021
77
TX
+1 to the above, the donner supply isn’t isolated, it’s basically a branded daisy chain unfortunately. Especially for power supplies you get what you pay for with budget friendly stuff.

Glad you got it worked out.
 


Latest posts

Top